ProBuilder Integration

Updated: 2019-08-08

Peek integrates with ProBuilder to include vertices, edges and faces in the Probe tool.

To enable this integration, follow the instructions below:

Unfortunately, due to differences in how Unity handles dependencies and assembly definition files across version, we couldn't make this process automatic. Sorry!


Unity 2018

  1. Install ProBuilder:
    1. Open Window > Package Manager
    2. Look for ProBuilder in the list and select it
    3. Click Install
  2. Add ProBuilder dependencies:
    1. Select Assets/Ludiq/Ludiq.Peek/Editor/Ludiq.Peek.Editor.asmdef
    2. Under Assembly Definition References, add:
      1. Unity.ProBuilder
      2. Unity.ProBuilder.Editor
    3. Click Apply
  3. Add ProBuilder scripting define:
    1. Go to Edit > Project Settings... > Player
    2. Under Scripting Define Symbols, add PROBUILDER_4_OR_NEWER
    3. Hit enter to apply
  4. Let Unity recompile
  5. Done! ProBuilder elements should appear in the Probe menu
1. Install ProBuilder
1. Install ProBuilder
2. Add Assembly Dependencies
2. Add Assembly Dependencies
3. Add Scripting Defines
3. Add Scripting Defines

If you update Peek and overwrite the asmdef file, you will have to go through this process again. To avoid this, you can uncheck this file when importing a new version of the package.


Unity 2019 or above

  1. Install ProBuilder:
    1. Open Window > Package Manager
    2. Look for ProBuilder in the list and select it
    3. Click Install
  2. Add ProBuilder dependencies:
    1. Select Assets/Ludiq/Ludiq.Peek/Editor/Ludiq.Peek.Editor.asmdef
    2. Under Assembly Definition References, add:
      1. Unity.ProBuilder
      2. Unity.ProBuilder.Editor
  3. Add ProBuilder version defines:
    1. Scroll down to Version Defines and click the + symbol
    2. Under Resource, choose com.unity.probuilder
    3. Under Define, write PROBUILDER_4_OR_NEWER
    4. Under Expression, write 4.0.0
    5. Click Apply
  4. Let Unity recompile
  5. Done! ProBuilder elements should appear in the Probe menu
1. Install ProBuilder
1. Install ProBuilder
2. Add Assembly Dependencies
2. Add Assembly Dependencies
3. Add Version Defines
3. Add Version Defines

If you update Peek and overwrite the asmdef file, you will have to go through this process again. To avoid this, you can uncheck this file when importing a new version of the package.

Was this article helpful?
Be the first to vote!
Yes, helpful
No, not for me